I'm a Freezy Pop.
Behold the magnificent and immaculate ramblings of an insane stick of frozen water with some sugar added.
User avatar
DrNiggle
Featured Broadcaster
Featured Broadcaster
 
Posts: 120
Joined: Tue Jul 23, 2013 8:58 am
Location: Georgetown, MA
Blog: View Blog (11)
Archives
- January 2015
BACK
   Sat Jan 31, 2015 9:37 pm

+ February 2014
+ November 2013
+ October 2013
+ September 2013
+ August 2013
+ July 2013
Search Blogs

My Rig Died

Permanent Linkby DrNiggle on Tue Feb 25, 2014 9:14 pm

Mobo failure :(

So my MSI P7N and its Q8200 processor are gone forever (died the first week in January), and I've been scrambling to come up with enough funding to buy a GIGABYTE GA-X79-UP4, an i7-4930K Ivy Bridge-E and some RAM (apparently no one uses 800MHz DDR2 anymore, whatever that's all about).

Unfortunately because my system was so old I also have to replace an IDE-DVD burner (which is actually only $30, I plotzed) and I'll admit that it has been about 5 years since I installed a mobo, so fingers crossed I don't destroy the thing screwing it in. Oh, and the brand new Zalman copper fan I got for Christmas won't fit onto an LGA2011 socket, so I'm also going water-cooled. That's another $120 or so.

This is definitely the most expensive hobby I've ever had. :lol: Sorry to everyone I've been playing with, I miss you and I'm working as best I can to get what I need and find the time to make a come-back!

Image

Want to have an adventure? PM me or find me in game!
0 Comments Viewed 694 times

Who is online

Registered users: Bing [Bot], Google [Bot]


Blogs powered by User Blog Mod © EXreaction